
2024 年 11 月 6 日
Cyclone 3DR 2024.1.3
新增功能
Cyclone 3DR 2024.1.3 是一个小版本发布,包含用于提升稳定性的缺陷修复。
根据维护到期日政策,在 2024 年 7 月 6 日处于维护期内的用户可访问 2024.1 版本,无需新的许可证。
改进
- File > Import LandXML: 现已支持 HeXML 2.1。
- Script: 新增函数 SCloudIterator.GetIntensity(),可用于查询某个点的强度值。
- Script: 新增按 Intensity 值设置点云显示方式的功能(SCloud::CloudRepresentationTypeEnum)。
缺陷修复
- Analysis > Statistics: 该功能在处理带有检查值的多段线时无法工作。已修复。
- File > Send To: Send To / Send From Hexagon Mineplan 3D 已随 2024 年 11 月版本的 Mineplan 3D 修复。
- Script: Curbature 函数尽管返回了有效的返回信息(ErrorCode1)却没有给出结果。已修复。
- Script: SCloud.FlipIntensities 返回了错误的结果。已修复。
- Viewset: 视点集中丢失了文本属性。已修复。
技术更新
- IFCOpenShell library: 更新至 2.13 版本,以修复 libxml2 的漏洞问题。
已知问题
- Documentation Center(文档中心)仅提供英文版本。
- 可能会出现一些 CAD 导入和导出问题。建议使用 Send to CAD 功能。
- DXF 可以用标准版本导入,而 DWG 需要 AEC 或 PRO Edition。一种变通方法是使用 AutoCAD 中的 3DR Send 命令发送到 Cyclone 3DR。
通用规格
Leica Cyclone 3DR 2024.1.3 兼容性
- Cyclone 3DR 兼容 CLM 2.14.0 及更高版本。
- Cyclone 3DR 兼容 LGS/LGSx 文件。
- Cyclone 3DR 兼容 Cyclone ENTERPRISE 2022.0 及更高版本。
- Cyclone 3DR 兼容 Cyclone REGISTER 360 2021.1 及更高版本。
- Cyclone 3DR 兼容来自 Cyclone 6.0 或更高版本的 Cyclone IMP 数据库,但只有来自 Cyclone 9.3 或更高版本的 IMP 才能获得改进后的渲染效果。
推荐的计算机配置
桌面应用程序中的常规工作流:
- CPU:2 GHz 双四核 i7 或更高(最低 i5)
- 64 位操作系统所需内存 RAM:
- 最低 16 GB
- 建议 32GB 或更多
- 显卡:NVidia Quadro 或 GeForce 1 GB(支持 OpenGL,版本 4.3 或更高)
- 操作系统:Microsoft Windows 10(Build 1809)、11(支持 64 位)
- 硬盘:3 GB 可用磁盘空间
用于 Touch Mode 的平板设备:
- Microsoft Surface PRO Core i7 1.5 GHz – 16GB RAM。
Auto-classification 的最低配置要求(在桌面应用程序其他推荐配置之外:
- 内存 RAM:最低 32 GB
- 显卡:具备 GPU 能力的 NVidia 显卡
- Compute capability(计算能力): 5.0 或更高
- 最低 GPU 显存:4 GB
- 硬盘:10 GB 可用磁盘空间
- CUDA® 11.8 Toolkit(来自 NVidia)。Auto-Classification 必须使用 11.8 版本的 CUDA。
安装与许可建议
安装更新步骤
- 启动 Cyclone 3DR EXE 并按照 Setup Wizard 中的说明操作
2. 选择更新 Cyclone 3DR 的选项(如果想更改安装选项,则选择修复)
3. 选择 “Install” 完成安装。

许可设置
- 安装 Cyclone 3DR 后,通过 Cyclone 3DR(Home/Settings/License)或通过位于以下位置的程序,打开用于 Floating(浮动) 许可证的 Client License Manager:
Start Menu | All Programs | Leica Geosystems | Client License Manager

务必选择 CLM Floating 选项(共有两个 CLM 选项,Nodelocked CLM 不会激活你的许可证)。
2. 单击 Add。
3. 在字段中输入你的 Entitlement ID(EID)(复制 / 粘贴)。如需输入多个 EID,请用分号 “;” 分隔且不留空格。
4. 输入 EID 后,单击页面右下角的 Add 按钮。
5. 许可证激活后,你可以关闭 CLM 并启动或返回 Cyclone 3DR。
6. 转到 Home | Settings 并选择 License。
7. 如果你在本地 CLM 中输入了 EID,请选择 Localhost。如果许可证位于专用服务器上,请在 Server Address 中输入该服务器的名称。
8. 你可以从 CLM 中选择想要签出的功能。可供签出的选项将对应于你购买并包含在 EID 中的选项。
9. 选择选项后,单击 Activate license。

许可
所有持有有效 CCP、或截至 2024 年 7 月 6 日有效的 CCP 的 Cyclone 3DR 用户,均可运行此新版本的 Cyclone 3DR。
所有持有有效 CCP、或截至 2024 年 7 月 6 日有效的 CCP 的 3DReshaper 用户,均可运行此新版本的 Cyclone 3DR,无需新的许可证。CCP 已过期的 3DReshaper 许可证用户必须迁移到 Cyclone 3DR,才能继续获取更新与支持。如需了解更多信息,请联系你的销售或支持人员。
所有持有有效 CCP、或截至 2024 年 7 月 6 日有效的 CCP 的 Cyclone SURVEY 用户,均可运行此新版本的 Cyclone 3DR(仅限 Standard 和 Survey Edition 功能)。
所有持有有效 CCP、或截至 2024 年 7 月 6 日有效的 CCP 的 Cyclone MODEL 用户,均可运行此新版本的 Cyclone 3DR(仅限 Standard 和 Plant Edition 功能)。
互操作性
导入 / 导出支持的文件格式
关于各许可证支持的完整文件类型列表,请参阅 Cyclone 3DR Technical Specification。
| Import(导入) | Export(导出) | |
|---|---|---|
| Point Cloud(点云) | ASCII 文件 (.asc, .csv, .xyz, .yxz…) Leica Geosystems (.pts, .ptx) 与 LGS/LGSX (.LGS/LGSx) Leica Nova MS50/60 (.sdb, .xml) ShapeGrabber (.3pi) 3DReshaper 二进制文件 (.nsd) AutoDesk DXF (.dxf) STL (.stl) Polyworks (.psl) Leica T-Scan + Steinbichler (.ac) LIDAR 数据 (.las; laz) 其他 ASCII (.) Zoller and Fröhlich (.zfs - .zfc) 不含三角面的 PLY 点 (.ply) ESRI ASCII(栅格格式 .asc) FARO (.fls - .fws) POLYWORKS (.psl) E57(.E57 文件) LandXML 文件 (.xml) Riegl (.RDBX) | ASCII 文件 (.asc, .csv…) 二进制文件 (.nsd) Leica Geosystems (.pts, .ptx, LGSx) E57 (.e57) IGES (.igs) LAS (.las) LAZ (.laz) Autodesk DXF (*.dxf) |
| Mesh(网格) | STL 格式 (.stl) 二进制 PBI 格式 (.pbi) DXF 3Dface 格式 (.dxf) Ascii POLY 格式 (.poly) OBJ 格式 (.obj) Ascii Leica 格式 (.msh) OFF 文件 (.off) PLY (.ply) GLB 格式 (.glb, gltf) | Ascii 与二进制 STL 格式 (.stl) 二进制 PBI 格式 (.pbi) DXF 3Dface 格式 (.dxf) Ascii POLY 格式 (.poly) 仅顶点 (.asc) DXF 多段线 (.dxf) Ascii Leica 格式 (.msh) PLY (.ply) LandXML (.xml) OBJ 格式 (.obj) GLB 格式 (.glb) FBX 格式 (.fbx) IFC / IFCSite 类型 (.ifc, .ifczip) |
| Contour / Section(等高线 / 剖面) | IGES 格式 DXF 多段线格式 二进制 MLI 格式 (*.mli) | IGES 格式 DXF 多段线格式 二进制 MLI 格式 (*.mli) ASCII 格式 |
| CAD / BIM Models(CAD / BIM 模型) | IGES STEP DWG IFC RVT | IGES STEP DXF IFC(管道模型) |
| Project(项目) | Cyclone 3DR (*.3dr) DXF - DWG XML Cyclone ModelSpace View(来自 IMP) | Cyclone 3DR (*.3dr) DXF PDF 3D SKETCHFAB |
| Report(报告) | PDF CSV BCF | |
| Image(图像) | BMP JPEG JPG PNG | 含地理配准信息的正射影像(以 TXT 文件形式) JPG JPEG BMP PNG TIF(仅正射影像) |
| Trajectory (mobile scanner)(轨迹,移动扫描仪) | Leica Geosystems (*LGSx) | Leica Geosystems (*LGSx) |
Send To / Send From
Cyclone 3DR 也提供 “SendTo” 功能,用于与第三方产品之间导入和导出某些类型的数据。更多信息可在 Cyclone 3DR 文档中心中获取(通过软件的帮助菜单)。
| Send From(发送自) | Send To(发送至) | |
|---|---|---|
| Point Cloud(点云) | - | - |
| Mesh / Surfaces(网格 / 曲面) | Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD | Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD |
| Contour / Section / Points(等高线 / 剖面 / 点) | Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD | Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD |
| CAD Model(CAD 模型) | Autodesk AutoCAD Hexagon BricsCAD | - |
| Image(图像) | - | Autodesk AutoCAD(正射影像) Hexagon BricsCAD |
Cyclone 3DR 中的以下命令包含直接的 “Send to” 能力,可将输出结果导出到 CAD 第三方软件产品中的不同图层:
| Menu(菜单) | Feature(功能) | Comment(备注) |
|---|---|---|
| Extract | Contour Lines | 标准等高线及其数值占 1 个图层。计曲线及其数值占 1 个图层。 |
| Extract | Scan to Plan | 每个剖切(平面图或剖面)占 1 个图层 |
| Extract | Virtual Surveyor | 在 3DR Virtual Surveyor 项目中创建的每个图层占 1 个图层。 |
| Extract | Scan to Pipe | 每条管道迹线占 1 个图层 |
| Analysis | Gridded Inspection Surface Analysis with a Grid | 网格上的点和数值可以直接发送到 CAD 软件产品。发送到当前活动图层。 |
| Texturing | Extract Orthoimage | 发送到当前活动图层。 |
| Analysis | Profile Extraction Profile 3D Inspection Profile 2D Inspection | 2D 网格占 1 个图层 检查对象占 1 个图层 每个剖面占 1 个图层 每个轴线点占 1 个图层 每个轴线点标注占 1 个图层。 |
| Tank | 2D Preview / Export |
与原生 JetStream 点云的兼容性
以下命令可以将原生 JetStream 点云(LGS/LGSX 文件,或连接到 Cyclone CORE、Cyclone REGISTER 360、Cyclone ENTERPRISE)作为输入。换言之,在执行所列功能之前,无需先进行 CloudWorx > Convert project 步骤。
| Menu(菜单) | Feature(功能) | Comment(备注) |
|---|---|---|
| Extract | Virtual Surveyor | 该功能无需选择任何对象。因此,它可用于 3DR 项目中的任何类型对象。 |
| Extract | Scan to Plan | |
| Surface Modeling | Scan to Mesh | 建议输入一个裁剪框,以定义感兴趣区域。 |
| Analysis | Stockpile | |
| Analysis | FF/FL Analysis | 工作流第一步中会给出最大点数。建议保留较高的值,以便在稠密点云上执行准确的分析。 |
| Analysis | Visual Notes | 该功能无需选择任何对象。因此,它可用于 3DR 项目中的任何类型对象。 |
View、CloudWorx 和 Script 菜单的功能显然也可以用于 JetStream 点云。
自 Cyclone 3DR 2024.1.0 版本起具备从 LGSx 文件流式传输图像的能力,因此不再需要转换项目即可查看相机图像。不过,当图像用于特定功能时,仍然需要对其进行转换:
| Menu(菜单) | Feature(功能) | Comment(备注) |
|---|---|---|
| Texture | Smart Texture Standard Texture Edit Mask | 当用户预期会使用带图像的处理流程进行纹理映射时,必须转换 LGSx 中的图像。 |
| Image object usage | Group / Ungroup | 在树视图中,只有从 LGSx 文件转换而来的图像才能成组和取消成组。 |
连接到 Cyclone FIELD 360
从 Cyclone FIELD360 到 Cyclone 3DR(2024.0 及更高版本)项目的连接仅限于 TLS 传感器:
- P-Series
- RTC360
- BLK360、BLK360 G1
导出 BCF tickets
以下命令具备导出 BCF(BIM Collaboration Format)文件的能力,这些文件包含来自 IFC 模型的信息,以便与其他软件和 BIM 解决方案实现开放 BIM 体验。
Cyclone 3DR 2024.1 支持 BCF 2.1 格式(导出)。
| Menu(菜单) | Feature(功能) | Comment(备注) |
|---|---|---|
| Analysis | Inspection Notes | 输入:被检查的 BIM 模型 用于报告检查中发现问题的功能,可创建手动注释,其中包含截图、来自磁盘的图像、标签和偏差值(附 CSV)、裁剪对象信息以及视点的坐标和朝向;此外还包含用户自定义的标题、指派对象(电子邮件地址)、备注和优先级。 |
| Analysis | Visual Notes | 输入:BIM 模型 用于基于 BIM 设计模型与实景捕获结果的目视分析来报告评论和注释的功能。该功能可创建手动注释,其中包含截图、来自磁盘的图像、距离测量值、裁剪对象信息以及视点的坐标和朝向;此外还包含用户自定义的标题、指派对象(电子邮件地址)、备注和优先级。 |
| Analysis | Clash | 输入:一个点云和一个 BIM 模型 用于报告碰撞的功能,其中包含截图、碰撞状态(碰撞、无碰撞或未定义)和备注。所有 ticket 都指向同一个指派对象(电子邮件地址)。 |
| Analysis | Progress Monitoring | 输入:一个点云和一个 BIM 模型 用于报告进度监测分析的功能。默认导出内容包含一份摘要(已安装、进行中、未安装和无数据之间的进度分布)。可自定义导出内容,并可根据各被分析元件的状态(已安装、未安装、进行中)创建额外的单条 ticket。所有 ticket 都指向同一个指派对象(电子邮件地址)。 |
| Touch Mode | BIM Inspection | 输入:一个点云和一个 BIM 模型 “Touch Mode” BIM Inspection 工作流也提供创建 BCF 问题的方式。其内容与从 “Inspection notes” 导出的注释类似,后者是 BIM Inspection 的桌面端对应功能。 |
分类体验
用于分类的交换格式
点云的分类结果会被保存,并支持以下交换方式:
- Import and Export(导入与导出):LGSx、E57、LAS、LAZ
- Stream and Convert(流式传输与转换):来自 Reality Cloud Studio, powered by HxDR
模型
在 Cyclone 3DR 2024.1 版本中,Auto-Classification 功能提供以下分类模型。
| Name(名称) | Application(应用) | Used scanners for training(训练所用扫描仪) | Other recommendations(其他建议) | Features using class information(使用类别信息的功能) |
|---|---|---|---|---|
| Indoor Generic | 室内 – 全部 | 全部 | 适用于 Scan to Model 工作流。 | |
| Indoor Construction Site | 室内 – 全部 | 全部 | 适用于 “Scan to Verify” 工作流,例如用于竣工核验。 | Progress Monitoring |
| Outdoor for TLS | 室外 – 全部 | TLS | 通用分类,也可与其他传感器类型配合使用。 | |
| Heavy Construction UAV | 室外 – 重型施工 | UAV 传感器 | 仅推荐用于重型施工环境。也可与其他传感器类型配合使用。 | 适合在 Virtual Surveyor、DTM 之前执行 |
| Mobile BLK Filter People | 全部 | BLK2GO 和 BLKARC | 仅推荐与 BLK2GO 和 BLKARC 配合使用。清理移动的人员和物体。 | |
| Road for MMS | 道路 | TRK 系列 | 推荐与所有 MMS 传感器配合使用,与 RTC360 和 BLK360 等 TLS 扫描仪配合进行提取也很有用。 | 适合在 Virtual Surveyor、DTM 之前执行 |
| Plant | 工厂设施、MEP 环境 | 全部 | 推荐与静态扫描仪配合使用 | 适合在 Scan to Pipe 之前执行 |