徕卡三维激光扫描产品中文培训与文档中心

Evidence Log(证据日志)

Evidence Log

中文 原文更新:— 查看英文原文 ↗

功能

Active Editor 是 Map360 的 Active Drawing Technology 的核心组件。Active Editor 是一种类似电子表格的网格浏览器/编辑器,可让你以交互方式处理图形以及项目坐标数据、原始导线数据和批量 COGO 数据。Active Editor 表现为一个带菜单栏的可自定义框架窗口。你可以在 Active Editor 中同时打开多个不同的文件,每个文件(或称为文档)都由 Active Editor 中的一个 View 窗口表示。我们为上述三种数据类型分别指定了不同的视图类型,即:

  • Active Coordinate Editor – 项目坐标数据库的视图。
  • Active Traverse Editor – 原始导线文件的视图。
  • Active Triangulation Editor - 批量三角测量文件的视图。

这些文档类型各有自己的一套菜单和功能,可用于处理你的数据。菜单栏和可用功能会根据你当前选中的文档类型而变化。

操作步骤

所有文档类型通用

在绘图窗口中平铺 Active Editor

坐标、导线或批量 COGO 文档可以平铺到框架窗口中,而框架窗口又可以平铺到绘图窗口中。为了在单显示器系统上高效地同时使用图形和 Active Editor,Active Editor 被设计为可通过 Window 菜单命令平铺到绘图窗口中:

编辑器中的许多功能对所有文档类型都通用。这些信息列示如下:

EvidenceLog1.png

靠左平铺 Active Editor

将 Active Editor 平铺到绘图区的左边缘,并占用绘图窗口的指定百分比(参见下文的平铺选项)。

靠右平铺 Active Editor

将 Active Editor 平铺到绘图区的右边缘,并占用绘图窗口的指定百分比(参见下文的平铺选项)。

靠上平铺 Active Editor

将 Active Editor 平铺到绘图区的上边缘,并占用绘图窗口的指定百分比(参见下文的平铺选项)。

靠下平铺 Active Editor

将 Active Editor 平铺到绘图区的下边缘,并占用绘图窗口的指定百分比(参见下文的平铺选项)。

平铺选项

平铺选项允许你设置一个百分比,用于控制 Active Editor 窗口框架可占用绘图窗口的多少空间。

EvidenceLog2.png

在 Active Editor 中使用视图

Active Editor 能够同时显示多个不同数据文件(文档)的视图。这些文档视图各自代表受支持的数据类型之一,目前这些类型为:坐标数据、导线数据和批量 COGO 数据。合理组织与布局这些文档视图,可以更高效、更强大地使用 Active Drawing Technology。

最大化视图

首次打开 Active Editor 时,视图会针对当前文档最大化。当你打开更多文档时,Window 菜单会维护一个列表,你可以从中选择新的活动文档。

层叠视图

使用 Window | Cascade 可层叠显示所有活动文档的视图。下图显示了 Cascade 命令的结果。

EvidenceLog3.png

执行 Window | Cascade 之后

平铺视图

视图也可以水平或垂直平铺,以充分利用 Active Editor 窗口框架的尺寸和范围。对于较高较窄的 Active Editor 窗口,水平平铺可能更有用;而对于较宽较矮的窗口,垂直平铺可能更合适。

EvidenceLog4.png

Window | Tile Horizontally 命令的结果

EvidenceLog5.png

Window | Tile Vertically 命令的结果

IntelliMouse 支持

Active Editor 中的 IntelliMouse 支持与 Microsoft Excel 和 Microsoft Internet Explorer 中的 IntelliMouse 支持非常相似。Active Editor 支持以下功能:

  • 滚动鼠标滚轮进行滚动
  • 按住 SHIFT 并滚动鼠标滚轮进行水平滚动
  • 按住 CTRL 并滚动鼠标滚轮进行放大和缩小

EvidenceLog6.png

缩放前

EvidenceLog7.png

缩放后 - 单击鼠标滚轮按钮并向上、下、左、右拖动鼠标可自动滚动。 - 鼠标滚轮按钮的 ClickLock:只需单击并按住鼠标滚轮按钮片刻,你的单击即被锁定。使用 ClickLock,只需拖动鼠标即可非常轻松地滚动网格(与 Autoscroll 类似,但无需一直按住鼠标滚轮按钮)。再次单击可解除 ClickLock。

从 Active Editor 打印

Active Editor 支持对所有数据类型进行集成的 Windows™ 打印和打印预览。你可以使用 File | Print 和 File | Print Preview 命令打印坐标、导线或批量 COGO 列表。

FILE 菜单

Print

选择正确的打印机以及要打印的页数/份数。

EvidenceLog8.png

EvidenceLog9.png

为打印机设置打印属性和选项。

EvidenceLog10.png

Page Setup

使用 Page Setup 定义 Active Editor 网格数据在打印页面上的属性。下面这个对话框允许你调整此处列出的页面设置:

Margins 用于指定打印边距。
Preview 预览网格,让用户可以在将更改应用回网格之前实时查看这些更改。
Page Order 单选按钮,用于指定网格分多页打印时的页面顺序。
Center on Page 复选框,用于指定网格打印时的垂直和水平居中。以下复选框可用于自定义列/行标题和网格线:
Row Headers 指定是否打印行标题。
Column Headers 指定是否打印列标题。
Print Frame 指定打印时是否在网格周围绘制边框。
Vertical Lines 指定是否打印垂直网格线。
Horizontal Lines 指定是否打印水平网格线。
Only Black and White 指定是否仅以黑白两色打印网格。
Save Settings to Profile 使用 Save settings to profile 复选框可保留你的页面设置。

EvidenceLog11.png

Header/Footer

你可以使用 Header/Footer 对话框输入希望包含在所有打印输出页眉或页脚中的特定信息,并可设置一些选项,例如自动页码。

Header/Footer 对话框允许你输入文字文本,例如公司名称或项目名称,也可以使用诸如 $D(当前日期)之类的标记,这些标记会在打印时被替换为相应的值。

目前支持以下标记:

  • $F - 文档文件名
  • $P - 当前页码
  • $N - 总页数
  • $D - 当前日期

字体可以通过选择一个单元格或单元格区域,然后单击字体按钮来更改。此时会显示标准字体对话框,用户可进行必要的更改。通过其 OK 按钮关闭字体对话框后,更改将应用回所选单元格。

EvidenceLog12.png

Preferences

你可以使用 File | Preferences 选项设置所显示坐标数据的颜色、字体和对齐属性。Styles 对话框会显示三种样式:Standard、Row Header 和 Column Header。要更改所显示坐标数据的外观,请从列表中选择 Standard 样式,然后单击 Change>> 按钮。

EvidenceLog13.png

首选项对话框会显示三个选项卡:Color、Font 和 Align。颜色页面可用于为 Active Coordinate Editor 网格选择背景色。使用字体页面可以设置字体类型、大小和颜色。设置好所需的颜色和字体特性后,单击 OK。在 Styles 对话框中,如果要保存设置,请务必勾选 Save as default 选项。单击 OK 按钮以应用更改并退出。

EvidenceLog14.png

首选项对话框:Color 页面

EvidenceLog15.png

首选项对话框:Font 页面