徕卡三维激光扫描产品中文培训与文档中心

2025.1.2 | Cyclone 3DR Release Notes

中文 原文更新:— 查看英文原文 ↗

3DR 横幅

说明

2025-06-11

Cyclone 3DR 2025.1.2

新增功能

Cyclone 3DR 2025.1.2 是一个小版本,包含提升稳定性的缺陷修复。

根据维护到期日政策,2025-01-01 处于维护期内的用户可访问 2025.1.x 版本,无需新的许可。

改进

  • Script: 现在可以在 SCloud 对象上操作点云属性(例如强度、时间戳、分类)。详情请查阅 SAttributeUtil()。
  • Script: 新增了 STexturingUtil.RemoveUnusedTextures() 方法,用于手动清除网格上未使用的纹理。
  • Script: 已解决脚本引擎的问题,以避免发生 RAM 溢出,并提升脚本化工作流的性能。

已修复问题

  • Coord Sys > Translation: 当定义了向量长度时,可能会出现不一致的行为。已修复。
  • File > Export to DXF: 无法导出仅包含 2 个点的多段线。已修复。
  • File > Export to LGSx: 当 3DR 项目中没有打开任何 LGSx 时,无法导出 LGSx 点云。已修复。

已知问题

  • Documentation Center 仅有英文版本。
  • 可能会出现一些 CAD 导入和导出问题。建议使用 Send to CAD 功能。
  • 如果 DXF 可以用标准版本导入,则 DWG 需要 AEC 或 PRO Edition。一种变通方法是使用 AutoCAD 中的 3DR Send 命令发送到 Cyclone 3DR。
  • 当 CloudWorx for AutoCAD 2025 在最新版本的 Cyclone 3DR 之前安装时,CAD 应用程序可能找不到 Send to AutoCAD 2025。变通方法如下:
  • 卸载 CloudWorx for AutoCAD 2025
  • 更新 Cyclone 3DR(最新版本)
  • 重新安装 CloudWorx for AutoCAD 2025

通用规格

Leica Cyclone 3DR 2025.1 兼容性

  • Cyclone 3DR 与 CLM 2.22.0 及更高版本兼容。
  • Cyclone 3DR 与 LGS/LGSx 文件兼容。
  • Cyclone 3DR 与 Cyclone ENTERPRISE 2022.0 及更高版本兼容。
  • Cyclone 3DR 与 Cyclone REGISTER 360 2021.1 及更高版本兼容。
  • Cyclone 3DR 与 Cyclone 6.0 或更高版本的 Cyclone IMP 数据库兼容,但只有在 Cyclone 9.3 或更高版本的 IMP 上才能看到改进后的渲染效果。

计算机配置

计算机配置 最低 推荐 包含自动分类 Cyclone 3DR Touch Mode 推荐配置
CPU 2 GHz 双四核 i7 或更高(最低 i5) 3.5 GHz Intel® Core™ i7 或更高 Microsoft Surface PRO Core i7 1.5 GHz
64 位操作系统的 RAM 16-32 GB RAM 64-256 GB RAM 16 GB
显卡 NVidia Quadro 或 GeForce 1 GB - 支持 OpenGL,版本 4.3 或更高 具备 GPU 能力的 NVidia - Compute capability(计算能力): 5.0 或更高,最高至 9.0 - 最低 GPU 显存:4-8 GB(尤其是三角形数超过 4000 万的网格)
操作系统 Microsoft Windows 10(Build 1809)、11(支持 64 位)
硬盘可用空间 3 GB 20 GB 3 GB
其他 CUDA® 11.8 Toolkit(来自 NVidia)。Auto-Classification 必须使用 CUDA 11.8 版本。

安装与许可建议

安装更新流程

  1. 启动 Cyclone 3DR EXE,并按照 Setup Wizard(安装向导)中的说明操作

image-20240712-073001.png 2. 选择更新 Cyclone 3DR 的选项(如果要更改安装选项,则选择修复)

image-20240712-073028.png 3. 通过选择 “Install” 完成安装。

image-20240712-073101.png

许可设置

  1. 安装 Cyclone 3DR 后,通过 Cyclone 3DR(Home/Settings/License)或通过位于以下位置的程序打开用于 Floating(浮动) 许可证的 Client License Manager:

Start Menu | All Programs | Leica Geosystems | Client License Manager

image-20240712-073453.png

注意

务必选择 CLM Floating 选项(有两个 CLM 选项,Nodelocked CLM 不会激活您的许可证)。

image-20240712-072648.png 2. 单击 Add。 3. 在字段中输入您的 Entitlement ID(EID)(复制/粘贴)。要输入多个 EID,请用分号 ";" 分隔,且不加空格。

image-20240712-072821.png 4. 输入 EID 后,单击页面右下角的 Add 按钮。 5. 许可证激活后,您可以关闭 CLM,然后启动或返回 Cyclone 3DR。

image-20240712-074422.png 6. 转到 Home | Settings 并选择 License。

image-20240712-074031.png 7. 如果您已在本地 CLM 中输入 EID,请选择 Localhost。如果许可证位于专用服务器上,请在 Server Address 中输入服务器名称。

image-20240712-074212.png 8. 您可以选择要从 CLM 检出的功能。可检出的选项将与您购买的、包含在 EID 中的选项相对应。

image-20240712-074249.png 9. 选择完选项后,单击 Activate license。

image-20240712-074329.png

许可

所有持有 Cyclone 3DR 有效 CCP、或在 2025-01-01 时有效的 CCP 的用户,都可以运行此新版本的 Cyclone 3DR。

所有持有 3DReshaper 有效 CCP、或在 2025-01-01 时有效的 CCP 的用户,无需新许可证即可运行此新版本的 Cyclone 3DR。CCP 已过期的 3DReshaper 许可证用户必须迁移到 Cyclone 3DR,才能继续获得更新和支持。更多信息请联系您的销售或支持人员。

所有持有 Cyclone SURVEY 有效 CCP、或在 2025-01-01 时有效的 CCP 的用户,都可以运行此新版本的 Cyclone 3DR(仅限 Standard 和 Survey Edition 功能)。

所有持有 Cyclone MODEL 有效 CCP、或在 2025-01-01 时有效的 CCP 的用户,都可以运行此新版本的 Cyclone 3DR(仅限 Standard 和 Plant Edition 功能)。

互操作性

导入/导出支持的文件格式

有关按许可证划分的受支持文件类型的完整列表,请参阅 Cyclone 3DR Technical Specification。

导入 导出
点云 ASCII 文件(.asc、.csv、.xyz、.yxz…)Leica Geosystems(.pts、.ptx)与 LGS/LGSX(.LGS/LGSx)Leica Nova MS50/60(.sdb、.xml)ShapeGrabber(.3pi)3DReshaper 二进制文件(.nsd)AutoDesk DXF(.dxf)STL(.stl)Polyworks(.psl)Leica T-Scan + Steinbichler(.ac)LIDAR 数据(.las; laz)其他 ASCII(.)Zoller and Fröhlich (.zfs - .zfc) 无三角面的 PLY 点(.ply)ESRI ASCII(栅格格式 .asc)FARO(.fls - .fws)POLYWORKS(.psl)E57(.E57 文件)LandXML 文件(.xml)Riegl(.RDBX) ASCII 文件(.asc、.csv…)二进制文件(.nsd)Leica Geosystems(.pts、.ptx、LGSx)E57(.e57)IGES(.igs)LAS(.las)LAZ(.laz)Autodesk DXF(*.dxf)
网格 STL 格式(.stl)二进制 PBI 格式(.pbi)DXF 3Dface 格式(.dxf)Ascii POLY 格式(.poly)OBJ 格式(.obj)Ascii Leica 格式(.msh)OFF 文件(.off)PLY(.ply)GLB 格式(.glb、gltf) Ascii 和二进制 STL 格式(.stl)二进制 PBI 格式(.pbi)DXF 3Dface 格式(.dxf)Ascii POLY 格式(.poly)仅顶点(.asc)DXF 多段线(.dxf)Ascii Leica 格式(.msh)PLY(.ply)LandXML(.xml)OBJ 格式(.obj)GLB 格式(.glb)FBX 格式(.fbx)IFC / IFCSite 类型(.ifc、.ifczip)
等高线/剖面 IGES 格式 DXF 多段线格式 二进制 MLI 格式(.mli)线形(.landXML) IGES 格式 DXF 多段线格式 二进制 MLI 格式(*.mli)ASCII 格式
CAD / BIM 模型 IGES STEP DWG IFC RVT COE IGES STEP DXF IFC(管道模型)
项目 Cyclone 3DR(*.3dr)DXF - DWG XML Cyclone ModelSpace View(来自 IMP) Cyclone 3DR(*.3dr)DXF PDF 3D SKETCHFAB
报告 PDF CSV BCF
图像 BMP JPEG JPG PNG 带地理配准信息的正射影像,以 TXT 文件形式提供 JPG JPEG BMP PNG TIF(仅正射影像)
轨迹(移动扫描仪) Leica Geosystems(*LGSx) Leica Geosystems(*LGSx)

Send To / Send From

Cyclone 3DR 也提供 “SendTo” 功能,用于与第三方产品之间导入和导出某些类型的数据。更多信息可在 Cyclone 3DR documentation center(从软件的帮助菜单进入)中获取。

Send From Send To
点云 - -
网格 / 曲面 Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD
等高线 / 剖面 / 点 Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD
CAD 模型 Autodesk AutoCAD Hexagon BricsCAD -
图像 - Autodesk AutoCAD(正射影像)Hexagon BricsCAD

Cyclone 3DR 中的以下命令具备直接的 “Send to” 能力,可以将输出导出到 CAD 第三方软件产品中的不同图层:

菜单 功能 备注
Extract Contour Lines 标准等高线及其数值 1 个图层。主要等高线及其数值 1 个图层。
Extract Scan to Plan 每个剖切 1 个图层(平面图或剖面)
Extract Virtual Surveyor 在 3DR Virtual Surveyor 项目中创建的每个图层对应 1 个图层。
Extract Scan to Pipe 每条管道轨迹 1 个图层
Extract Points on Grid 所有文字 1 个图层
Analysis Gridded Inspection Surface Analysis with a Grid 网格上的点和数值可直接发送到 CAD 软件产品。发送到活动图层。
Texturing Extract Orthoimage 发送到活动图层。
Analysis Profile Extraction Profile 3D Inspection Profile 2D Inspection 2D 网格 1 个图层 检查对象 1 个图层 每个剖面 1 个图层 每个轴线点 1 个图层 每个轴线点标注 1 个图层。
Tank 2D Preview / Export

与原生 JetStream 点云的兼容性

以下命令可以使用原生 JetStream 点云(LGS/LGSx 文件或连接到 Cyclone CORE、Cyclone REGISTER 360、Cyclone ENTERPRISE)作为输入。换言之,在执行所列功能之前,无需先进行 CloudWorx > Convert project 步骤。

菜单 功能 备注
Extract Virtual Surveyor 此功能无需选择对象。因此,它可用于 3DR 项目中的任何类型的对象。
Extract Scan to Plan
Surface Modeling Scan to Mesh 建议输入一个 clipping box(限界框)以定义感兴趣区域。
Analysis Stockpile
Analysis FF/FL Analysis 在工作流的第一步中会给出一个最大点数。建议保留较高的值,以便在密集点云上执行准确的分析。
Analysis Visual Notes 此功能无需选择对象。因此,它可用于 3DR 项目中的任何类型的对象。

View、CloudWorx 与 Script 菜单的功能显然也可以用于 JetStream 点云。

由于自 Cyclone 3DR 2025.1.0 版本起具备从 LGSx 文件流式传输图像的能力,不再需要转换项目即可查看相机图像。但是,当图像用于特定功能时,仍然需要进行转换:

菜单 功能 备注
Texture Smart Texture Standard Texture Edit Mask 当用户预期使用图像进行纹理工作流时,必须从 LGSx 转换图像。
Image object usage Group / Ungroup 在树视图中,只有从 LGSx 文件转换后的图像才能被分组和取消分组。

连接到 Cyclone FIELD 360

从 Cyclone FIELD360 连接到 Cyclone 3DR(2024.0 及之后版本)项目仅限 TLS 传感器:

  • P-Series
  • RTC360
  • BLK360、BLK360 G1

导出 BCF 工单

以下命令内置了导出 BCF(BIM Collaboration Format)文件的能力,这些文件包含来自 IFC 模型的信息,以便与其他软件和 BIM 解决方案实现开放 BIM 体验。

Cyclone 3DR 2025.1 支持 BCF 2.1 格式(导出)。

菜单 功能 备注
Analysis Inspection Notes 输入:被检查的 BIM 模型 用于报告检查中发现问题的功能,能够创建手动注释,其中包含截图、来自磁盘的图像、标签与偏差值(附 CSV)、裁剪对象信息以及视点的坐标与朝向;此外还包含用户定义的标题、分配对象(电子邮件地址)、备注和优先级。
Analysis Visual Notes 输入:BIM 模型 用于基于 BIM 设计模型与实景捕获的视觉分析来报告评论与注释的功能。该功能能够创建手动注释,其中包含截图、来自磁盘的图像、距离测量、裁剪对象信息以及视点的坐标与朝向;此外还包含用户定义的标题、分配对象(电子邮件地址)、备注和优先级。
Analysis Clash 输入:一个点云和一个 BIM 模型 用于报告碰撞冲突的功能,其中包含截图、碰撞状态(碰撞、无碰撞或未定义)和备注。所有工单都指向同一个分配对象(电子邮件地址)。
Analysis Progress Monitoring 输入:一个点云和一个 BIM 模型 用于报告进度监测分析的功能。默认导出包含摘要(已安装、进行中、未安装和无数据之间的进度分布)。可以自定义导出,并根据每个被分析元素的状态(已安装、未安装、进行中)创建额外的单独工单。所有工单都指向同一个分配对象(电子邮件地址)。
Touch Mode BIM Inspection 输入:一个点云和一个 BIM 模型 “Touch Mode” BIM Inspection 工作流也提供创建 BCF 问题的方式。其内容与从 “Inspection notes” 导出的注释类似,后者是 BIM Inspection 的桌面端等价功能。

外部文件的管理

为确保其应用的灵活性,Cyclone 3DR 提供了一种管理某些外部文件的方式,目的是让用户能够更便捷地配置软件。

本节的目的是说明可通过 Cyclone 3DR 使用的外部文件的可能性与类型。

对于每个功能/方面,用户可以:

  • 从 Cyclone 3DR 用户界面构建每个文件的初始版本
  • 从 Cyclone 3DR 导出或导入到 Cyclone 3DR
  • 在其他软件工具(notepad、excel……)中编辑该外部文件

借助这些功能,用户可获得的好处包括:

  • 节省重复性工作的时间
  • 轻松使用自己偏好的设置
  • 与同事及组织内部协作
  • 针对每个项目、每类终端客户优化配置

当前的工具如下:

名称 菜单 功能 文件扩展名 内容 用例示例 图示
Class standard File > Settings Classification XML - 该列表默认由 Hexagon 标准列表定义,包含 256 个索引。此 Hexagon 标准在使用点云分类的 Hexagon 产品之间普及,并符合 ASPRS 对前 64 个索引的定义。 - 用户可以自定义这 256 个类别中每个索引的名称、颜色与 “favorite” 状态。 - Hexagon 标准列表可一键恢复,这对于 Reality Capture 产品之间统一的体验以及适配新模型非常重要。 - 该列表可以导出为 XML 并重新导入。 - 在特定工作中使用 Manual Classification 时,用户可以编辑新类别(颜色与名称),以确保所有 Cyclone 3DR 项目保持一致。 - 用户可以针对使用特定标准的客户调整名称和颜色。之后,用户可以在需要对另一个项目重复该操作时保存一个 XML 文件以节省时间。 a.png
Feature code standard Extract Virtual Surveyor Points on Grid CSV 可从 Virtual Surveyor 功能访问这些设置。可以管理两种类型的 CSV: - Layers(资产的颜色 + 名称 + 像素尺寸) - Feature Codes(图层 + 颜色 + 名称 + 索引开头 + 描述) - 用户必须按照终端客户(Department of Transportation、Municipality、Local authority……)定义的标准交付地形图。 - 从任何类型的文本类文件中理解 Cyclone 3DR 模板,并在电子表格中创建自定义的 Layers 和 Feature Codes 列表,都非常容易。 image-20241125-105137.png
Colormap definition Analysis Edit colors Gradient Scripting RSI 对于任何着色/被检查的对象(点云、模型、多段线),用户可以在检查功能内部或通过 “Edit Colors” 功能编辑颜色渐变。借助 Save / Load 功能,重复性分析中复用特定颜色渐变非常方便。要构建 RSI 文件,最好的方式是在 Cyclone 3DR 用户界面中创建并保存为 RSI。用户可以定义: - 范围, - 步长, - 颜色, - 数值, - 单位。 常规或重复性的设计对比竣工核验: - 为特定制造商或特定类型的对象定义按容差标准化的颜色映射。 - 应用场景众多:制造、BIM、道路或隧道分析…… image-20241125-105512.png
Report template Report Template Library Scripting MLT 借助 Cyclone 3DR 内置的报告编辑器,有各种适配不同章节类型的模板: - 通用方面(页脚、页眉……) - 分析(Stockpile、Compare/Inspect……) - 图像定位 - 统计 - Tank Inspection 工作流 在线文档中有一个专门的帮助页面用于说明这些模板的内容。 用户可能需要针对自己的客户定期执行每周扫描对比竣工图的报告。借助 MLT 文件,他可以轻松保存并复用一个模板,用于这些重复性分析报告。 image-20241125-110525.png
Camera parameters Texturing Estimate Pose Scripting INCAMEXCAM 1. INCAM 文件 - INCAM 文件通常包含相机内部参数。这些参数对摄影测量流程至关重要,因为它们描述了用于采集图像的相机的固有属性。 - 内部参数可能包括焦距、主点坐标、镜头畸变系数以及其他标定数据,这些有助于从 2D 图像准确地重建 3D 模型。 2. EXCAM 文件 - EXCAM 文件通常存储相机外部参数。这些参数描述相机在空间中相对于给定坐标系的位置与朝向。 - 外部参数包括相机的位置(X、Y、Z 坐标)及其朝向(旋转角度或旋转矩阵)。这些参数对于将多张图像或点云对齐到同一参考框架至关重要。 这些文件在以下情况下很有用: - 根据相机拍摄的一组照片手动定义相机参数 - 编辑不受支持的扫描仪所拍摄照片的相机参数。INCAM 文件可以通过 Calibrate Camera 命令一次性生成。也可以通过脚本进行批量编辑。EXCAM 文件可以通过 Estimate Pos 命令按图像生成。 image-20241125-164242.png
Matrix file Coord Sys N points Registration Best Fit Registration TXT 将 3D 变换的定义以矩阵形式存储在文件中。 - 在两个对象之间应用最佳拟合,并将结果导出到另一个软件。 - 对同一项目进行重复性最佳拟合操作 image-20241125-165223.png

分类体验

用于分类的交换格式

点云的分类会被保存,并支持以下交换方式:

  • 导入与导出:LGSx、E57、LAS、LAZ
  • 流式传输与转换:来自 Reality Cloud Studio,由 HxDR 提供支持

模型

在 Cyclone 3DR 的 2025.1 版本中,Auto-Classification 功能中提供以下分类模型。

名称 应用 用于训练的扫描仪 其他建议 使用类别信息的功能
Indoor Generic 室内 – 全部 全部 适用于 Scan to Model 工作流。
Indoor Construction Site 室内 – 全部 全部 适用于 “Scan to Verify” 工作流,例如竣工核验。 Progress Monitoring
Outdoor for TLS 室外 – 全部 TLS 通用分类,也可用于其他传感器类型。
Heavy Construction UAV 室外 - 重型施工 UAV 传感器 仅推荐用于重型施工环境。也可用于其他传感器类型。 适用于在 Virtual Surveyor、DTM 之前执行
Mobile BLK Filter People 全部 - BLK2GO - BLKARC - BLK2FLY 推荐用于移动 BLK 系列。清理移动的人员和物体。
Road for MMS 道路 TRK 系列 推荐与所有 MMS 传感器配合使用,并且对 RTC360 和 BLK360 等 TLS 扫描仪进行提取时也很有用。 适用于在 Virtual Surveyor、DTM 之前执行
Plant 工厂设施、MEP 环境 全部 推荐与静态扫描仪配合使用 适用于在 Scan to Pipe 之前执行